Resetting Connection to DJI Server

When trying to upgrade or downgrade firmware on your controller or aircraft, the firmware version drop down menu does not show up on the device information screen.

Cause:

  1. Poor connection to WiFi.
  2. Poor connection with DJI server.

Solutions:

  1. Test using multiple WiFi sources.
    1. This will allow you to test whether or not your internet connection is causing issues between you and the DJI Servers.
  2. Restart the RC and aircraft.
    1. This will reset the connection between the two devices to see if there is a communication problem.
  3. Turn the controller off and on 5 times quickly.
    1. This will involve you turning off the controller then turning it on then back off as soon as the image of drones pops up on the screen 5 times in a row.
    2. This resets the connection with DJI’s server and the controller and allows the RC to refresh what comes up on the device information screen.

Conclusion:

Oftentimes firmware drop down menu will not come up on the controller screen because it has not been given enough time to connect to the servers and pull up new firmware versions. This process can sometimes take up to 10 minutes before the option to update the firmware or the menu to change firmware will show up. Almost always does restarting the RC 5 times in a row fix the issue.